Automotive Message Board

Go Back   Automotive Message Board > General Motors Corporation > General Motors Corporation > Chevrolet > Chevy S-10
FORUMS Register FAQ Members List Calendar Search Today's Posts Mark Forums Read

Chevy S-10 Forum for discussions in regards to the Chevrolet S-10

Car Forum: Chevy S10 Sputters on the Highway. Feels like it someone is tapping the brakes,...
Reply
 
Thread Tools
  #1  
Old 03-12-2008, 11:08 PM
Donny J Donny J is offline
Junior Member
 
Join Date: Mar 2008
Posts: 1
Chevy S10 Sputters on the Highway. Feels like it someone is tapping the brakes,...

...and I THINK I heard misfire.? The S10 sputters on the Hwy around 55+, I tried to go as fast as 85 and it didnt go away so I slowed down to 70, which gets you ran off the road on the FL turnpike.
-Check Engine Light came on w/ 3 codes: Weak signal from TPS sensor, EGR valve, weak signal from Fuel Pump
-I bought a new fuel pump assembly and it didnt help at all
-Truck idles, and drives around town perfectly
-Started a couple of days ago on the way down to Miami, didnt stop on the way back to Orlando
-Craziest part, I tailgated (almost at a dangerous level) with a semi truck for an hour and it drove perfectly, AS SOON as the semi exited and I was left alone the problem came right back

I dont want to guess and spend money on parts I dont need, especially since I already bought and installed a fuel pump.

I REALLY think it is a wiring/bad wire problem. What else could it be, or how do I find a bad wire. Where should I start looking???

This thing has me flat out stumped...

BTW, S10 for sale LOL
__________________
Web Services by Yahoo!
Reply With Quote

  #2  
Old 03-12-2008, 11:09 PM
Ski-Doo Man Ski-Doo Man is offline
Junior Member
 
Join Date: Mar 2008
Posts: 1
I had this exact same problem with my S-10. Turned out to be a faulty/fouled spark plug (champion). I had just replaced them about a week previous, so I didn't think that could be it. I replaced the spark plugs (I used NGK this time... gap them first!) and it fixed the problem.

Remember, always start with the cheapest solution first and work your way up!
__________________
Web Services by Yahoo!
Reply With Quote
  #3  
Old 03-12-2008, 11:13 PM
db667089 db667089 is offline
Junior Member
 
Join Date: Jan 2008
Posts: 19
Your EGR may need to be cleaned. Did you replace your fuel filter? Make sure gap is correct on spark plugs...it's critical.
__________________
Web Services by Yahoo!
Reply With Quote
Reply


Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 12:33 AM.


Powered by vBulletin® Version 3.6.10
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.