• In case you hadn't noticed, this community is SPAM FREE. Wonder why? Because it's actively maintained. If you're planning on posting anything non-automobile related, don't waste your time. We have 24 hour coverage.

85 Ford Bronco II Help?

Homie

New member
I just bought a 1985 Ford Bronco II, 5-speed manual V6 2.8L. She's a beauty...but she has her problems. She has two mechanical problems that I want to have addressed.

1.) She needs to get warm before properly functioning. I have to let her idle for at least 15mins or she gets real temperamental. It feels like the fuel isn't getting to engine. I'll have the accelerator pressed in, hear my RPM's go up (no tachometer) and hear it die or feel it die as I let it the clutch to find no power.

Also part of this same problem if I haven't driven her for a few hours, not sure of the time gap, she will stall out in idle when starting. This happens even when I'm trying to feed her fuel with the accelerator. After 3 or 4 attempts she can idle on her own.

But after warmed up, she runs just fine. Thinking either fuel pump or fuel filter.

2.) Sometimes she squeaks. It sounds like it's coming from the driver's side front wheel. It's not a belt or anything with the motor cause it doesn't pick up when I hit the gas but depends on the wheel speed. It happens randomly, sometimes it's there other times it's not. It doesn't sound bad and don't think it's a real problem but I just would like to know what it is. All I can keep thinking is "squeaky wheel gets the oil".

Appreciate any help I can get.
 

Latest posts

Top